Jailbreak your iPhone

Downgrade iPhone 3G 3.1.3 Baseband 05.12.01 With Fuzzyband


FuzzyBandGood news for those who upgraded their iPhone 3G to OS 3.1.3 and lost their baseband. As you know Apple introduced a new baseband 05.12.01 with iPhone OS 3.1.3 update, and latest baseband 05.12.01 is  un-hackable at the moment because Ultrasn0w/Blacksn0w doesn’t support. Bigboss released Fyzzyband 3.1.3-1 a while ago in Cydia. Fuzzyband Downgrader is a safer iPhone 3G Baseband Downgrader as this one detects your baseband and bootloader version and does the right thing first.

In other words Fuzzyband Downgrader detects your bootloader and baseband and downgrade it with a simple click if your bootloader is vulnerable to Fuzzyband . Fuzzyband Downgrader available in Cydia, just refresh your sources and search for Fuzzyband and install the application

Please Note :

  • Downgrading works from any version greater than 4.26.08. It will put your baseband back at version 4.26.08 which is hackable by ultrasn0w.
  • Downgrading only works on iPhone 3G with 05.08 (5.8) Bootloader from the factory. This is a very limited number of phones that were released in the first few weeks of the 3G production cycle.
  • If you do not know your bootloader then you can run Fuzzyband and it will report the version number for you.
  • iPhone 3GS and large numbers of iPhone 3G aren’t supported by the Fuzzyband, so in case your baseband is updated then wait for Dev team/GeoHot to release any workaround. This may take weeks or months.

Stay tuned with us for your daily dose of iPhone news, you can follow us on twitter via @ihackinjosh You can also subscribe to our daily free e-mail news letter and keep your self updated with the latest of iPhone community.


Comments ( 27 )

Have Something To Say ?

  1. Nikhil Mehta March 20, 2011 Reply

    Downgrade iphone baseband from 6.15.00: I get err “downgrading will only work with baseband bootloader 06.04″?

    I have been trying to downgrade my Iphone 3g’s baseband from 6.15.00 to anything lower, but Fuzzyband gives me the error” downgrading will only work with baseband bootloader 06.04″;
    I followed link: http://www.redmondpie.com/how-to-downgrade-iphone-06.15.00-baseband-to-05.13.xx-iphone-3g-bootloader-5.8-only/ but it tells you that it will only work with bootloader 5.8;
    My bootloader version is: 06.04
    Is there any chance that i can downgrade my baseband with my current bootloader?
    Are there any plans on getting a fix for this??

  2. Applejuiced October 14, 2010 Reply


  3. Mr. Andi October 12, 2010 Reply

    hi, is any solution to unlock a 3G with OS 4.1, baseband 5.14.02?
    It’s already JB-ed. The bootloader is 6.04

  4. Mr.aiman October 8, 2010 Reply

    I’m but i’m trying to return my iphone 3gs to it’s
    Original virsion 3.1.3 after update to 4.0.
    But i’can i mean i don’t fid the silution would you tell me how i return it.

    Thank you to much.

  5. Dustin June 25, 2010 Reply

    YES FINALLY SOMEONE CAME OUT WITH THIS! Glad I didnt have to pay. This gives great details. I jailbroke and unlocked mine with this webiste.


    thanks again! being able to unlock this will make alot of people happy!

  6. Raju.kr June 22, 2010 Reply

    Hi I am able to unlock my 2 iphone 3gs 3.1.3 05.12.01 and 06.04 with Spriit Jailbreak and ultrasn0w latest upgrade from cydia .

    Wow Thanks to dev team [cydia] to provide new update. Hats off Dev Team guys to kick Apple guys ass again 🙂 .

    Steps which I have followed .

    1.) Jail break using Spirit
    2.) installed ultrasn0w version through cydia [But no luck for 15 days]
    3.) just today 21-June-2010 got new ultrasnow update from cydia . and now I am able to use my other carriar cell sims like T-mobile etc…

    if any body want any help , you can send mail to my mail id. rajsys2007@gmail.com


  7. hixon June 15, 2010 Reply

    hi guys hi admins my iphone 3gs os 3.1.3 fw 05.12.01 bootloader 06.04 how to unlock help me pls help me pls help me pls help me pls pls reports
    pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports pls reports

  8. shaanu June 7, 2010 Reply

    please help me ma i phone 3g version is 3.1.2.(7d11) and modem Firmware is 05.12.01 , i cant use sim card what shold i do..? please help me..please

  9. real baks May 27, 2010 Reply

    here, I have a serious problem with my iphone3g OS 3.1.3 loader: 06.04 baseband:05.12.01 !!!!! or another solution??,
    I want to unlock to use any sim
    help me please! that makes three weeks that I no longer communicate
    my address: bakastras02@hotmail.com

  10. Sassy May 3, 2010 Reply

    I have been doing research and from what I see, the 4G looks like some myth and legend, been around since this time last year… There are people who have been wiating almost half the year already for this ‘fortold’ release… Looks like whoever is holding the golden egg of release on the code unlocking is going to be keeping their secret a very long time. Glad I did my research before attempting a jailbreak and locking my phone up for a long time. good luck to you all on your search

  11. santu May 2, 2010 Reply

    any body can solve problem 3.1.3 Firmware 05.12.01 bootloder 5.09.(MB496NF) 3G iphone unlock.i need any body can help me.

  12. B April 5, 2010 Reply

    There is no downgrader for baseband 06.04

    If you have 06.04, you’re basically screwed until a hack is released.

    Could be waiting until the new OS comes out or the new iPhone comes out. Hopefully with the release of the iPad, it’ll come sooner.

  13. Sarmad April 3, 2010 Reply

    can i downgrade my baseband bootloader from 06.04 to 05.08

  14. DR April 1, 2010 Reply

    you cannot downgrade bootloader 6.4 and unlock your phone as of right now unless your phone is a 1st producton 3g that had bootloader 5.08 (5.8) installed on it from the factory – if you download fuzzyband and it says it will not work then you don’t have a 1st production 3g and your phone cannot be unlocked as of yet and just because 4G might come out in the near future (I heard maybe not till next year) does not mean there will be a unlock for it.

    ***this is for all the other people in here that can’t read – the bootloader # is not the same as the baseband # – baseband 5.12.01 can be downgraded if your phone originally had bootloader 5.08(5.8) installed on it from the factory, if fuzzyband doesn’t work for you it’s because you DO NOT have a phone that had bootoader 5.08(5.8) installed on it from the factory***

  15. Joe March 29, 2010 Reply

    How can I downgrade a bootloader 6.4 to unlock my Iphone

  16. Humam March 22, 2010 Reply

    Dear All,

    If you upgraded your iPhone to 3.1.3 and modem to 05.12.01 then you have to wait till Apple releases the 4G, then you can unlock and jailbreak it, so guys you have to wait for about 2-3 weeks hopefully.

  17. Toni March 20, 2010 Reply

    You guys need to come up with something to downgrade bootloader version; 06.04[G2M3S2]………….

  18. blak icon March 18, 2010 Reply

    so in order for this to be used i already had to of had my iphone jailbroken??

  19. Jurriaan665 March 16, 2010 Reply

    I’m also stuck with the latest version, after my IPhone dropt out of juice it has (unwanted) installed the latest version. I miss my ‘normal’ IPhone the way it was. If somebody working on a way to jailbreak this latest version?
    I would be very welcome.


  20. daniel March 11, 2010 Reply

    fuzzyband doesnt work with baseband version 05.12.01 can anyone help?

  21. Shawn March 11, 2010 Reply

    It’s pretty much impossible to jailbreak a phone with modem firmware 05.12.01. Itunes updated mines and screwed me over! Hopefully a fix will come but it might take a long long time.

  22. Giva March 9, 2010 Reply

    Hey Guys,

    My iphone shows bootloader 6.04, is there a way to change it so i can unlock my phone, it is already jailbroken, i’ve got cydia and blackra1n on it already but fuzzyband wont downgrade it gives an error ” Sorry, downgrading will only work with baseband bootloader 05.08.
    Iphone OS Version is 3.1.2 and baseband is 05.12.01.
    Can any one help plz.

    Thanks in advance.

  23. Umair March 2, 2010 Reply

    I have Iphone 3GS with latest firmware 3.1.3 and the modem firmware is 5.12.01. I need to either jailbreak or to downgrade. If anybody can help me in this regard will highly be appreciated.

  24. Kandarp February 27, 2010 Reply

    @Betti.. 05.12.01 is baseband while 05.08 is bootloader. These are two different things. Sadly, i stuck with 05.08 bootloader 3G. If you’r not sure just make it run through cydia and it will let you know.

  25. Betti February 11, 2010 Reply

    Actually it seems that Fuzzyband doesn’t work with 05.12 but only with 05.08…
    What’s your advice?
    Thank you for your help

  26. MadSkrilla February 11, 2010 Reply

    So my iphone was 3.1.2 not sure what modem firmware it was though, i had it jailbroken and unlocked with blackra1n and had Cydia on it. Last night my itunes updated it to 3.1.3 and modem firmware 05.12.01 and all my apps i had gotten from jailbreaking it are now gone no blackra1n no cydia no rock and all my emulators/roms gone.

    Am i basically screwed now for trying to jail brake and unlock the thing? i originally got it unlocked so my sim card for the UAE (United Arab Emirates) would work on it, my Rogers one from canada still works on it but i am not in canada right now im still in the UAE so i kind of need to get it unlocked again.

    Is the only way to get this Fuzzyband thing on it through cydia? anything i can do to unlock again?

  27. jed February 11, 2010 Reply

    Great job. I got re-jailbreaking to my cell with ex-baseband.
    Thank you sincerely for your effort.

Leave your comment here